Смена mac-адреса в RouterOS

Произвести изменение mac-адреса в RouterOS от компании Mikrotik можно только через терминал. В WinBox, по неизвестным причинам, это сделать нельзя - поле с наименованием mac-адреса не редактируется (Interface -> выбрать нужный интерфейс -> MAC Adress -> Вкладка General (по умолчанию)).

Для смены mac-адреса в WinBox нужно открыть терминал - нажав на пункт меню New Terminal. В окне открывшегося терминала для начала нужно узнать номера и названия сетевых интерфейсов устройства:

/interface print

Flags: D - dynamic, X - disabled, R - running, S - slave
 #     NAME                               TYPE               MTU L2MTU  MAX-L2MTU
 0  R  ether1-master                      ether             1500  1520       1520
 1  R  ether2-wan                         ether             1500  1520       1520
 2     ether3-slave-local                 ether             1500  1520       1520
 3     ether4-slave-local                 ether             1500  1520       1520
 4     ether5-slave-local                 ether             1500  1520       1520

Как можно понять из полученных данных в примере (используется Mikrotik RB450G) к устройству подключены сетевые кабели на канал 0 и 1 с именами ether1-master и ether2-wan соответственно - подключение по сети обозначается литерой R. Номера каналов всегда постоянны и начинаются с нуля. Имена каналов - могут быть переименованы администратором. Сменить mac-адрес для 1-го канала с именем ether2-wan можно двумя способами: по имени и номеру канала:

Смена mac-адреса в RouterOS по номеру канала
/interface ethernet set 1 mac-address=00:XX:...:...:...:XX
Смена mac-адреса в RouterOS по имени канала
/interface ethernet set ether2-wan mac-address=00:XX:...:...:...:XX

Проверить, изменился ли MAC в роутере Mikrotik под управлением RouterOS можно зайдя в Interface -> выбрать нужный интерфейс -> MAC Adress -> Вкладка General (по умолчанию). Здесь же можно вернуть сетевому интерфейсу оригинальный заводской MAC-адрес, нажав кнопку Reset MAC Adress.

Опубликовано: 2012/10/01
HTML-код ссылки на эту страницу:
<a href="http://petrenco.com/routeros.php?txt=153" target="_blank">Смена mac-адреса в RouterOS от Mikrotik</a>
14679
Комментарии
т.е. таким способом можно менять не только мак роутера но и любого устройства в него подключенного?
Добавить комментарий
Ваш e-mail: (не виден посетителям сайта)
Ваше имя:
Комментарий:
Символы с картинки:
Только выделенные поля формы добавления комментариев обязательны к заполнению.